Fail Over Mikrotik

kebetulan ane punya 2 gateway… berhubung males pindah2in manual berpikir deh dikit untuk otomatis pindah gateway jika salah satu ada yang pudur

disini saya cuma memisahkan iix dan ix dengan nice nya mikrotik.co.id dan ntu saya tambahin port na games online..

so cekidot…

/ip address
add address=10.10.10.2/30 interface=ether1
add address=11.11.11.2/30 interface=ether2
add address=192.168.88.1/24 inteface=ether3
/ip route
add dst-address=8.8.8.8 gateway=10.10.10.1 check-gateway=ping routing-mark=GW1
add dst-address=8.8.4.4 gateway=11.11.11.1 check-gateway=ping routing-mark=GW2
add gateway=10.10.10.1 routing-mark=GW1
add gateway=11.11.11.1 routing-mark=GW2
/ip dns set servers=208.67.222.222,208.67.220.220 allow-remote-requests=yes
/ip firewall nat
add comment="FORCED DNS" chain=dstnat action=dst-nat to-addresses=208.67.222.222 to-ports=5353 protocol=udp dst-port=53 log=no log-prefix=""
add chain=dstnat action=dst-nat to-addresses=208.67.222.222 to-ports=5353 protocol=tcp dst-port=53 log=no log-prefix=""
add comment="NAT" chain=srcnat action=masquerade src-address=192.168.88.0/24 log=no log-prefix=""
/ip firewall mangle
add comment="GW1" chain=prerouting action=mark-routing new-routing-mark=GW1 passthrough=yes src-address=192.168.88.0/24 dst-address-list=nice log=no log-prefix=""
add comment="BGW1" chain=prerouting action=mark-routing new-routing-mark=GW2 passthrough=yes src-address=192.168.88.0/24 dst-address-list=nice log=no log-prefix=""
add comment="GW2" chain=prerouting action=mark-routing new-routing-mark=GW2 passthrough=yes src-address=192.168.88.0/24 dst-address-list=!nice log=no log-prefix=""
add comment="BGW2" chain=prerouting action=mark-routing new-routing-mark=GW1 passthrough=yes src-address=192.168.88.0/24 dst-address-list=!nice log=no log-prefix=""
add comment="ICMP" chain=output action=mark-packet new-packet-mark=icmp passthrough=yes protocol=icmp log=no log-prefix=""
add chain=input action=mark-packet new-packet-mark=icmp passthrough=yes protocol=icmp log=no log-prefix=""
add comment="MIKROTIK" chain=output action=mark-packet new-packet-mark=mikrotik passthrough=no protocol=tcp dst-port=8291 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=mikrotik passthrough=no protocol=tcp dst-port=8291 log=no log-prefix=""
add comment="GAMES" chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=tcp port=20000,1818,2001,3010,4300,5105,5121,5126,5171,5340-5352,6000-6152,7777 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=tcp port=7341-7350,7451,8085,9600,9601-9602,9300,9376-9377,9400,9700,10001-10011 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=tcp port=10402,11011-11041,12011,12110,13008,13413,15000-15002,16402-16502,16666,18900-18909,19000 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=tcp port=19101,22100,27780,28012,29000,29200,39100,39110,39220,39190,40000,49100 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=udp port=1293,1479,6100-6152,7777-7977,9401,9600-9602,12020-12080,30000,40000-40010 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=udp port=42051-42052,11100-11125,11440-11460,14009-14026,15100-15150,30002-30020,11004 log=no log-prefix=""
add chain=prerouting action=mark-packet new-packet-mark=games passthrough=no protocol=tcp port=14009-14017,9601-9602,14300-14440,19000,6215,621,28901-28925,27932-27935,9100-9300 log=no log-prefix=""
/tool netwatch
add comment="Monitoring GW1" down-script="/ip firewall mangle disable [find c\
omment=\"GW2\"]\r\
\n/ip firewall mangle enable [find comment=\"BGW2\"]\r\
\n" host=8.8.8.8 interval=10s timeout=10s up-script="/ip firewall mangle e\
nable [find comment=\"GW2\"]\r\
\n/ip firewall mangle disable [find comment=\"BGW2\"]\r\
\n"
add comment="Monitoring GW2" down-script="/ip firewall mangle disable [find com\
ment=\"GW1\"]\r\
\n/ip firewall mangle enable [find comment=\"BGW1\"]\r\
\n" host=8.8.4.4 interval=10s timeout=10s up-script="/ip firewall mangle e\
nable [find comment=\"GW1\"]\r\
\n/ip firewall mangle disable [find comment=\"BGW1\"]\r\
\n\r\
\n"

 

apa lagi yah ? itu aja kali yah ? oya nice nya …

/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;
import nice.rsc

 

hohoho .. lupa lagih .. 😀 kiwing e … atur sesuai kebutuhan, ane paling demen pake pcq, puyeng ngurusin qiwing banyak pc wekwekwek

/queue simple
add name="* Mikrotik" target="" parent=none packet-marks=mikrotik priority=8/8 queue=default-small/default-small limit-at=0/0 max-limit=100M/100M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
add name="* Games" target="" parent=none packet-marks=games priority=1/1 queue=default-small/default-small limit-at=0/0 max-limit=100M/100M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
add name="ALL" target=192.168.88.0/24 parent=none packet-marks="" priority=8/8 queue=pcq-upload-default/pcq-download-default limit-at=0/0 max-limit=90M/90M burst-limit=0/0
burst-threshold=0/0 burst-time=0s/0s

 

semoga bermanfaat …

Iklan

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s